Back
Maintenance
Maintenance
FiveM Server Maintenance
Completed 28 Nov at 01:40pm HST.
G3N FiveM Services
G3N Database Services
Completed
Maintenance completed
Posted
28 Nov at 01:40pm HST.
Started
Please expect 20-30 minutes of downtime while we prepare the fivem server for season 2
Posted
28 Nov at 12:40pm HST.