Back
Resolved

Cfx.re Server Reviews & Server List Outage

Started 8 Nov at 02:21pm HST.

Created

Cfx.re's antiquated infrastructure has, once again, failed in deploying their new UI. This is not expected to have any affect on G3N FiveM services. Will continue to monitor.

Posted 8 Nov at 02:21pm HST.