Back
Maintenance
Maintenance
Server Migration & Upgrade
Completed 21 Jul at 03:06am HDT.
G3N FiveM Services
G3N Database Services
Completed
Maintenance completed
Posted
21 Jul at 03:06am HDT.
Started
As discussed, our provider is upgrading our machine to higher specifications than we previously purchased due to the fiasco that unfolded during that migration. Please allow 1-3hr of downtime.
Posted
20 Jul at 11:06pm HDT.